追学网

VLAN的配置命令

UPDATE:2014/10/29 | 分类:网站建设教程
  1.创建VLAN

  Catalyst2950交换机最多可以配置250个VLAN,VLAN ID取值为1~4094,其中1号 VLAN是自动生成的,不能删除,默认情况下,交换机的所有接口都属于VLAN1;1002~1005是保留给令牌环网和FDDI网络的,以太网中不能使 用;1006~4094属于扩展VLAN,一般也不要使用。所以在2950交换机上创建VLAN时,一般使用2~1001的ID号,使用时不必使用连续的 值。举例如下:

  sw2950#vlan database//vlan database命令用于进入VLAN配置状态

  sw2950(vlan)#vlan20name market//创建一个编号为20,名称为market的VLAN

  sw2950(vlan)#vlan30name sales//创建一个编号为30,名称为sales的VLAN

  sw2950(vlan)#exit

  sw2950(vlan)#no vlan20//删除VLAN20

  sw2950#show vlan//查看VLAN配置情况

  2.为VLAN分配端口

  sw2950(config)#interface fastethernet0/1//进入快速以太网0槽位的1号端口

  sw2950(config-if)#switchport access vlan20//将该端口分配给VLAN20

  sw2950(config-if)#interface fa0/11//进入0/11端口,fa为快速以太网的简写

  sw2950(config-if)#switchport access vlan30//将该端口分配给VLAN30

  sw2950#show interface f0/1//查看快速以太网0/1端口信息

  以上是一次将一个端口加入VLAN,如果要一次将一组端口加入某个VLAN,那么就要使用如下命令。

  例:在交换机SW1上分别将6~10端口、11~15端口划分到VLAN10、VLAN20

  SW1(config)#interface range fastethernet0/6-10

  SW1(config)#switchport mode access//将交换机端口模式设置为access模式

  SW1(config)#switchport access vlan10//将0模块的6-10端口划分为VLAN10

  SW1(config)#exit

  SW1(config)#interface range fastethernet0/11-15

  SW1(config)#switchport mode access

  SW1(config)#switchport access vlan20

  SW1(config)#exit

  3.Trunk的配置

   当两台或两台以上的交换机相连后,在没有划分VLAN时,连接在各交换机上的所有计算机都可以直接通信,但划分VLAN后,只有属于同一个VLAN的计 算机间可以通信,为了实现不同交换机中同一VLAN间的计算机可以相互通信,此时就要将交换机之间相连的端口定义为Trunk(干线)模式,而交换机间相 连的线称为VLAN中继或VLAN干线。通过在交换机相互连接的端口上配置中继模式,就可以使属于不同VLAN的数据帧都可以通过这条中继链路进行传输。

   而中继链路上接收到数据帧时,交换机必须采用某种方法来识别数据帧是属于哪个VLAN的,所以在配置Trunk时可以封装以下某种技术,需要说明的是通 常交换机在配置Trunk时采用默认的识别技术,所以一般不为Trunk链路设置封装协议。Cisco交换机支持以下4种识别技术。

  ISL:用于互连多台交换机的Cisco专有封装协议。

  IEEE802.1Q标准:通过在帧头插入一个VLAN标识符来标识VLAN,称为“帧标记”。

  局域网仿真:用于通过ATM网络传输VLAN的一种IEEE标准方法。

  802.10:在FDDI帧中传输VLAN信息的一种Cisco专有方法。

  交换机的端口模式分为Access模式、Trunk模式和Multi模式,默认情况下为Access模式。

  例:两台Cisco2950交换机相连用各自的12号端口,则将两台交换机12号端口都定义为Trunk模式。

  SW1(config)#interface fa0/12//进入快速以太网0槽位的第12号端口

  SW1(config-if)#switchport mode trunk//将该端口设置为Trunk模式

  SW1(config-if)#switchport trunk encapsulation dot1q//为Trunk链路封装802.1q协议

  另一台交换机的12号端口也按以上方法配置。配置完成后用“ping”命令进行验证,属于同一个VLAN的计算机间可以通信,属于不同VLAN的计算机间不能通信。

  4.配置VTP

   VTP(VLAN Trunk Protocol)全称为虚拟局域网中继协议,主要用来管理VLAN的删除、添加、修改等操作的一致性,在同一个VTP 域内,VTP通过中继端口在交换机间传送VTP信息,从而使一个VTP域内的交换机能够共享VLAN信息。所以,如果交换机数量较多,为了方便管理,可以 利用VTP对VLAN进行统一管理。

  VTP常用模式有服务端模式和客户端模式,作为服务端模式的交换机需要定义VLAN信息,并广播 给客户端使用,而作为客户端模式的交换机不需要定义VLAN编号,可以直接接收并使用来自服务端交换机的VLAN设置信息。如果在VTP服务器上把某 VLAN删除,则各个VTP客户端上相应的VLAN也会被删除。在此特别说明的是Cisco交换机具有此功能,而其他品牌的交换机在配置VTP时客户端可 能也需要创建VLAN信息。
学习网

世界看中国 娱乐情感文化观点视频